403 Forbidden when accessing the https://gitlab.com/api/v4/applications API


Currently trying to create a new application using the /applications API [1] on GitLab.com, but it always returning a 403 Forbidden error. I’ve tried this with a personal token that has all the available permissions, and this error still ocurrs. This can be reproduced by running the following command with a personal token:

curl --request POST --header "PRIVATE-TOKEN: redacted" --data "name=MyApplication&redirect_uri=http://some.address&scopes=api" https://gitlab.com/api/v4/applications/

Output: {"message":"403 Forbidden"}

The 403 Forbidden error also occurs even when listing the applications:

curl -X GET https://gitlab.com/api/v4/applications -H 'private-token: redacted'

Output: {"message":"403 Forbidden"}

It is worth noting that a regular user can go to its account and create an Applications manually, but it cannot be done programmatically through the /applications endpoint.

Any ideas or suggestions on how to proceed forward with this? Any help would be greatly appreciated.

Best regards,

Claudiu B.

[1] Applications API | GitLab

I am getting same error, any workaround for this?