500 error & no logs show problem

I have been running GitLab-CE omnibus for a while now but today it stopped working with error “500 Whoops, something went wrong on our end.”. I’m using CentOS 6.7 and checked under /var/log/gitlab but couldn’t find anything indicating the source of the 500 error. The nginx log showed the hit and 500 response but not anything in the error log.
I tried:
gitlab-rake cache:clear
gitlab-rake assets:precompile
gitlab-ctl reconfigure
gitlab-ctl restart

I also then (yum) updated to version 8.5.7 CE. and repeated the commands above to no avail. Is there any way of determining the source of 500 error like this?
The VM is dedicated to gitlab with (netstat) unicorn listening on 127.0.0.1:8080 and nginx on port 443 Browsing on the machine to 127.0.0.1:8080 also gives the 500 error. The gitlab-ctl restart shows all services as “ok: run”
Can anyone offer any advice?

Hi

Please run the below rake test to find out if there are any problems

sudo gitlab-rake gitlab:check SANITIZE=true --trace

I ran your command and it didn’t show any problems. I had a wee think and remembered that I had customised the login page with my own text and logo. I think that maybe after upgrading the changes I had made possibly conflicted with the upgraded newer versions of the files. So I yum removed the gitlab package (and did some clean up), then yum installed it again and restored from a backup. I am now up and running again and much less likely to hack the UI !
Thanks for your help,
jonny

1 Like

Hi Jonny

Good to hear that, Gitlab is up and running. Now Gitlab comes with Logo customization. You can follow the instructions for Changing the appearance of the login page