500 error page not just on the repo, in all pages

Hi, I’m getting a weird 500 error page when I did pushed a repo with a title Hugo on GitLab it’s a private repo, the repo around ~130K files because I uploaded the public folder to the GitLab repo, I wanted to try out the GitLab pages. The public folder around 3.76GB all HTM pages. The problem is after I uploaded those files to the repo, I’ve tried to open the repo on GitLab it keeps hanging for free seconds before it hits the limit and on the end gives 500 error page technical error. The issue it’s not only on the page of the repo it’s on the homepage also the first page works fine but when I’m trying to go to the second page it’s keeps hanging again … Even i tried to link the repo to Vercel but keeps hanging when trying to list the repos … And on the usage quota of the page gives NaN even tho before It was showing the size of repos around 250MB on storage, that’s a screenshot of what I’m talking about: https://image.prntscr.com/image/hck4BUxTSue6dAg_YybPVQ.png
I’ve tried to change the URL to go straight to edit page to delete the repo nothing works, please anyone got any idea. And looks like there’s a limit on the number of files that can exists within a repo but couldn’t found it anywhere. I’m using a Free GitLab account if this info could help.