502 Bad Gateway for gitlab after a yum update

Hi !

I had a gitlab environnement that was working fine on CentOS 6, using
port 8081 (apache already uses 80), and a yum update passed and now, I
can’t access my gitlab : 502 Bad Gateway
The issue is… I don’t understand much of what I’m doing. Configurating
gitlab at first was not easy… But this time, I don’t know what to do.

In nginx logs (nginx has been installed from gitlab), I have :
2016/01/28 18:37:37 [crit] 31765#0: *1 connect() to unix:localhost:8081 failed (2: No such file or directory) while connecting to upstream, client:, server: gitlab.mydomain.com, request: "GET / HTTP/1.1", upstream: "http://unix:localhost:8081:/", host: "gitlab.mydomain.com:8081"

I already tried to check the conf, to use gitlab-ctl reconfigure, restart, but this doesn’t seem to be changing anything at all.

Here is the result from gitlab-ctl show-config

gitlab-ctl show-config
[2016-01-28T18:42:27+01:00] WARN: Ohai::Config[:disabled_plugins] is set. Ohai::Config[:disabled_plugins] is deprecated and will be removed in future releases of ohai. Use ohai.disabled_plugins in your configuration file to configure :disabled_plugins for ohai.
Starting Chef Client, version 12.5.1
resolving cookbooks for run list: [“gitlab::show_config”]
Synchronizing Cookbooks:
- package (0.0.0)
- runit (0.14.2)
- gitlab (0.0.1)
Compiling Cookbooks…
“gitlab”: {
“bootstrap”: {

    "omnibus-gitconfig": {

    "manage-accounts": {

    "user": {
      "git_user_email": "gitlab@gitlab.mydomain.com"
    "redis": {

    "ci-redis": {

    "gitlab-rails": {
      "secret_token": "2e6c9197f8a81829348e8a29d0608976189abe04b0e28384428c49abcb8c8c9a5b95cfeac5b5f3e59",
      "gitlab_host": "gitlab.mydomain.com",
      "gitlab_email_from": "gitlab@gitlab.mydomain.com",
      "gitlab_https": false,
      "gitlab_port": 8081,
      "shared_path": "/var/opt/gitlab/gitlab-rails/shared",
      "artifacts_path": "/var/opt/gitlab/gitlab-rails/shared/artifacts",
      "lfs_storage_path": "/var/opt/gitlab/gitlab-rails/shared/lfs-objects",
      "pages_path": "/var/opt/gitlab/gitlab-rails/shared/pages",
      "db_username": "gitlab",
      "db_host": null,
      "db_port": 5432
    "gitlab-ci": {
      "secret_token": null,
      "secret_key_base": "18f7e0e892c1cba94454a289abc285492afvd42909fbez364c9a4a45efc7c092b678e5b6bb986383",
      "db_key_base": "3fd05caaefd2ez3d5c5abc184fezi71962480936de4674609a6802b",
      "db_username": "gitlab_ci",
      "db_host": null,
      "db_port": 5432
    "gitlab-shell": {
      "secret_token": "95f9af3zff567dcd70fbbc847dc67679d5e3717498294fhe97f978756f14bcca26f94b48db43f85008c1fab280d1e1ce3c21d4156369b"
    "unicorn": {

    "ci-unicorn": {

    "sidekiq": {

    "ci-sidekiq": {

    "gitlab-workhorse": {
      "listen_addr": "localhost:8081",
      "auth_socket": "/var/opt/gitlab/gitlab-rails/sockets/gitlab.socket"
    "mailroom": {

    "nginx": {
      "listen_port": 8081
    "ci-nginx": {
      "listen_port": 80
    "mattermost-nginx": {
      "listen_port": null
    "pages-nginx": {
      "listen_port": null
    "logging": {

    "remote-syslog": {

    "logrotate": {

    "high-availability": {

    "postgresql": {

    "web-server": {

    "mattermost": {
      "email_invite_salt": "5723719e29c111gr11c34905c25e838da",
      "file_public_link_salt": "ede2ceb23d88reg83cc7060852525050251",
      "email_password_reset_salt": "9a79cff28e13fe248e53c3a13dc0d1f3aee",
      "sql_at_rest_encrypt_key": "f57d4bf0284dff8db5691ffc489b3f8312a1",
      "sql_data_source": "user=gitlab_mattermost host=/var/opt/gitlab/postgresql port=5432 dbname=mattermost_production",
      "sql_data_source_replicas": [
        "user=gitlab_mattermost host=/var/opt/gitlab/postgresql port=5432 dbname=mattermost_production"
    "external-url": "http://gitlab.mydomain.com:8081",
    "ci-external-url": null,
    "mattermost-external-url": null,
    "pages-external-url": null
Converging 0 resources

Running handlers:
Running handlers complete
Chef Client finished, 0/0 resources updated in 01 seconds

I tried to update /var/opt/gitlab/nginx/conf/gitlab-http.conf , changing upstream gitlab-workhorse server from unix:localhost:8081 to localhost:8081, with that, I have an errror : 400 Bad Request Request Header Or Cookie Too Large, but I can’t see anything in nginx logs
But each time I gitlab-ctl reconfigure, this change in nginx conf is overwritten (it goes back to unix:localhost:8081). I tried setting this : gitlab_git_http_server[‘listen_network’] = “tcp” and reconfigure, but it doesn’t change anything.

If you have any pointers to what I could do/check, that would be
great because I am kind of stucked (and as I don’t understand much of
what I’m doing… That doesn’t help…)

Thank you !