520 Origin Error on uploading a generic package to the GL Package Registry

We have a weekly scheduled CI pipeline that generates and uploads a generic package (it’s a .zip file) to the Package Registry. This has been working perfectly fine until the last ~2 weeks, where we have been encountering the following error when uploading via curl:

% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 4905M    0   179  100 4905M      0  6836k  0:12:14  0:12:14 --:--:--    37
<html>
<head><title>520 Origin Error</title></head>
<body bgcolor="white">
<center><h1>520 Origin Error</h1></center>
<hr><center>cloudflare-nginx</center>
</body>
</html>

The .zip file we’re trying to upload is 4.8 GB, and we have multiple files (~2.3 GB) uploaded as generic packages to the same registry in the past.

Troubleshooting steps taken

  • Publishing the same package via CI/CD pipeline to a different repository’s Package Registry (but under the same group); same error.
  • Publishing the same package via the command line on a local machine; same error.
  • Publishing the same package with better compression (.7z file of 3 GB) via the command line on a local machine; same error.
  • Publishing an empty .zip file (0 bytes) via CI/CD pipeline; this works successfully and was uploaded with a 201 Created response.

As far as we are aware,

  • Generic packages have a size limit of 5GB per file (which we are within).
  • GitLab doesn’t currently have a limit on total Package Registry storage nor does it display how much storage is currently being used.

This makes it hard to confirm if this is being caused by a storage/size issue.

Is there anything else that could be causing this behaviour? And/or is there anything else we can try to solve this?

Thanks in advance!

1 Like

Did you solve this issue? I have an exact same problem.

Nope, the issue remains unresolved.

Same error here. We have noticed that the upload is occasionally successful but far from consistent. Is there a public issue tracker for the package registries?

Update:
Contacted GitLab Support and apparently the issue is currently being investigated.

Issue ticket: Investigate CF 520 during large generic package upload (#13249) · Issues · GitLab.com / GitLab Infrastructure Team / infrastructure · GitLab.

I’ve been advised to follow up with their progress there.

FYI @henryaw, @swysocki.ampere

1 Like