After mint upgrade, gitlab no longer starts

I had gitlab ce 11.10.8 running on mint 17.3 but this was very out of date. Previous updates had come via the mint repo but there had not been any for quite a while. Just to explain this is a play system but I would like to keep it up to date.
So I decided to update the OS to mint 18. This may have been a mistake. (Fortunately there are backups).
Anyway, the OS upgrade went well but gitlab no longer starts.
$ sudo gitlab-ctl status
fail: alertmanager: runsv not running
fail: gitaly: runsv not running
fail: gitlab-monitor: runsv not running
fail: gitlab-workhorse: runsv not running
fail: logrotate: runsv not running
fail: nginx: runsv not running
fail: node-exporter: runsv not running
fail: postgres-exporter: runsv not running
fail: postgresql: runsv not running
fail: prometheus: runsv not running
fail: redis: runsv not running
fail: redis-exporter: runsv not running
fail: sidekiq: runsv not running
fail: unicorn: runsv not running

I have not had this situation before - gitlab to its credit just worked after install.
Can someone explain what I have to look for to fix this.
Also, did gitlab stop updating the mint repo hence no new updates after 11.10.8?
And can I run the latest version of gitlab (13.x.x?) on mint 17.3 or do I have to upgrade the OS?

I changed the approach. I restored from backup so I had 17.3 mint / gitlab 11.10.8.
I upgraded to mint 18 and did not reboot. A ps -ef | grep gitlab showed lots of gitlab proceses.
I then installed gitlab 11.11.0 and upgarded postgres. This was successful - still lots of gitlab processes.
I then switched off the machine so that I could back up the VM.
Started VM and now ps -ef shows no gitlab processes.
A sudo gitlab-ctl start shows all fails - runsv not running.

So obviously something is not working.
Any ideas anyone?


afaik Linux Mint is based on Ubuntu. We do not provide packages specifically for Mint, so can you please share the package details which source you are using?

apt-cache showpkg gitlab

Depending on the package name, adjust gitlab to gitlab-ce or gitlab-ee.

Other than that, I’d suggest to use an officially supported distribution listed at


The key was gitlab-ctl reconfigure.
So after the OS upgrade and the gitlab upgrade then I run reconfigure after the reboot.
From that point, subsequent upgrades to get to the latest and greatest dif not require me to run reconfigure after a reboot.