After the update, we get an error in every pipeline - We are currently unable to fetch data for this pipeline

After the update, we get an error in every pipeline - “We are currently unable to fetch data for this pipeline.”
But at the same time, the jobs are executed.

GitLab 13.11.3
GitLab Shell13.17.0
GitLab Workhorsev13.11.3
GitLab APIv4
Ruby2.7.2p137
Rails6.0.3.6
PostgreSQL12.6
Redis6.0.12

Screenshot with an error, and so on in each pipeline:

Jobs:

Greetings,

I got the same error. In my case it seems the http request “LinkedPipelineData” is too long and returns a 400 “Bad Request” error due to excessive amounts of whitespace (it seems the message is not cleaned from Tabs). The messages length on my system is >5000 characters. Interestingly this error does not occur on our side if the Server and Browser are connected to the same switch.

Observing the google search results for “We are currently unable to fetch data for this pipeline.” A LOT of people are running into this problem.

Edit: I fixed it temporary on my machine by adding a redirect rule to the Firefox addon “Request Control”: {origin}{pathname}{search//(%20)+/%20} replacing all occurences of %20*n with %20.

Greetings,
Wsza

We’re hitting this too, on upgrade from 13.10.2 to 13.11.3. Is anyone aware of a (server side) workaround, or are we waiting on 13.11.4 for a fix?

This problem is related to the new graph page, so any affected customer on self-hosted can turn the feature flag off while we figure out a fix. In the rails console,

Feature.disable(:graphql_pipeline_details)

This will allow them to see the old graph for now which is not sending any graphQL query, so it will not fail

Hello I am also experiencing the issue.
I checked with Feature.enabled?(:graphql_pipeline_details) but it already disabled.
Ouptut was => false
Do you have any other idea ?

Try running the command to disable it anyhow. Mine also reported “false” but I ran the command to disable it anyhow and it resolved the issue.

irb(main):001:0> Feature.enabled?(:graphql_pipeline_details)
=> false
irb(main):002:0> Feature.disable(:graphql_pipeline_details)
=> true
irb(main):003:0> Feature.enabled?(:graphql_pipeline_details)
=> false

I can second this - the command brings back the old pipeline view.

Btw. the issue is tracked in #329895.