All domains on my server are forwarding to GitLab

Greetings everyone,

I have been looking around for some answers and have found some things to try but nothing seems to be helping. After installation of GitLab to a gitlab.domain.com, any subdomain results in a forward to the GitLab installation. However, beyond that, all other domains on the server also forward to the GitLab installation, for instance, OtherDomain.com forward to GitLab.domain.com.

I have been looking around the config and tried disabling nginx and using my apache installation, I have modified listening addresses and running the reconfigure command on each attempt. I even tried stopping GitLab which only partially worked in the sense that all traffic was forwarded to the GitLab subdomain but the page just wouldn’t serve. Given that, I am assuming that records in hosts file may be there or something like that.

Any Ideas?

EDIT:

I was able to restore operation by stopping GitLab and reenabling apache but my install does not seem to be honoring not using nginx and running GitLab in a named virtual host.