All repos empty after backup & restore

I’m in the process of upgrading our gitlab-ce installation (v11.10.4) which is currently running on Debian 9. I also want to upgrade the OS at the same time, I decide that the best way to do this was first duplicate what I have on to a 2nd server, complete the gitlab-ce upgrades to the latest version and then move the upgraded gitlab-ce installation to the Debian 11 server.

On our original server I stopped sidekiq & unicore services and ran gitlab-rake gitlab:backup:create SKIP=repositories. I grab the backup file, the required files from /etc/gitlab

I then copied the repositories to a mounted vhd, waited for that to complete.
Mounted the vhd on the new Debain 9 server under the same directory as is configured on the original server.
Restored the backup, copied the files to /etc/gitlab and ran gitlab-ctl reconfigure and logged into gitlab.

Upon browsing to the repositories they are all empty. It just gives me the option to import or create an empty repository. If I create a new project that project repo gets written to the same place as the other repositories (The mounted vhd) and I only have 1 path configured in gitlab.rb. If I browse the activity that is all correct, the commits are all correct. There are just no files there.

I’ve checked the permissions on the directory, I’ve created additional backups and repeated the process. I’ve even tried creating an empty repository and copying over the contents.

None of these have worked.