Anyone help me understand why Compare function says the files are different when they are same?

Please go to Torrentech / · GitLab and take a look at gitlab-ci.yml on main and dev branches - they are the same.

Now go use Repository>Compare utility and it tells that the files are different showing differences between current and previous version which seem to be stuck somewhere “in limbo”.

Don’t wanna say I found the bug but I really can’t explain this? Yes I was tweaking gitlab-ci-yml file in the GitLab interface on main, because I wanted to fast-test if it works, and when it worked out I merge the changes to dev, and the Compare function is broken for me from there on. And then I tried ti Revert that last change - Compare function stills says they are different, but they are the same because I manually edited the dev version to be the same as main, after I reverted.

Gotta admit it’s a whole lot of mess in my head now, anybody experienced take a look, probably I’m overseeing something crucial.


I noticed that when I choose ... (the option between source and target branches in the Compare interface, GitLab is telling file is the same, and when I choose .. that’s where it thinks they are different.

Thing was about different behaviour of git diff A…B and git diff A…B commands. Actually it seems everything was ok, but it was confusing for me.

Hi it is a challange for me i will try to my best to solve this