Autodevops with Kubernetes runner without Dockersim seems broken

Autodevops pipeline fails in build stage. Tested on new version of Kubernetes without docker.

Kubernetes Distro: k3s
Kubernetes Version: v1.23.6+k3s1

  • What are you seeing, and how does that differ from what you expect to see?
    Getting this error message in build job log:
    ERROR: failed to build: failed to fetch builder image 'index.docker.io/heroku/buildpacks:20': Cannot connect to the Docker daemon at tcp://localhost:2375. Is the docker daemon running?

  • Consider including screenshots, error messages, and/or other helpful visuals

  • What version are you on? Are you using self-managed or GitLab.com?
    Using GitLab.com

  • Add the CI configuration from .gitlab-ci.yml and other configuration if relevant (e.g. docker-compose.yml)
    .gitlab-ci.yml not present. Autodevops does not need one.

  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?
    I have tried it in another environment. I got the same error. I suspect the build job is looking for a docker deamon which does not exist. Not sure if autodevops can run on Kubernetes clusters that are not based on docker i.e. all latest Kubernetes distros which no longer have docker shim