Autoscaling GitLab CI on AWS Fargate - Getting source from Git repository - fatal: unable to access

I’m having trouble getting through the instructions for “Autoscaling GitLab CI on AWS Fargate
, specifically with step 7 :slight_smile:

Generally everything is clear, containers are deploying, fargate driver spawns new ci-coordinator, etc
In the pipeline I see that it even successfully connects to a container
“DEBU[2022-04-25T18:15:34Z] [connect] Will connect to server via SSH PID=42278 command=run_exec stage=get_sources”
DEBU[2022-04-25T18:15:34Z] [connect] Successfully connected to server PID=42278 command=run_exec stage=get_sources

The problem starts in the step “Getting source from Git repository”

DEBU[2022-04-25T18:15:34Z] [connect] Successfully connected to server PID=42278 command=run_exec stage=get_sources
DEBU[2022-04-25T18:15:34Z] [executeScript] Will execute a remote script PID=42278 command=run_exec stage=get_sources
Fetching changes with git depth set to 20…
Initialized empty Git repository in /opt/gitlab-runner/builds/xxxxxx/xxxxxxxx/.git/
Created fresh repository.
fatal: unable to access ‘https://gitlab-ci-token:[MASKED]@gitlab.com/xxxxxx/xxxxxxxx/’: Failed to connect to gitlab.com port 443: Connection timed out
DEBU[2022-04-25T18:17:44Z] [disconnect] Will disconnect from server PID=42278 command=run_exec stage=get_sources
DEBU[2022-04-25T18:17:44Z] [disconnect] Successfully disconnected from server PID=42278 command=run_exec stage=get_sources
ERRO[2022-04-25T18:17:44Z] Application execution failed PID=42278 error=“executing the script on the remote host: executing script on container with IP “xxx.xxx.xxx.xxx”: executing script: executing remote script: executing SSH command: Process exited with status 1”

And this error is a bit strange, because after ssh to such container and testing e.g. curl https://gitlab.com/ I get the content of the site, also clone git repository without any problem.

The project is private, maybe because of that I should configure something else?
I am looking for any ideas on what to do next.
I used the containers from the document, I also created my own, unfortunately the effect is the same