Can I update Gitlab CE from 11.10.8 to latest (13.x)

I have a Ubuntu Server 20.04.1.

I recently installed the Gitlab 11.10.8 to migrate from an older Ubuntu server to this new one.

So now I want to update this gitlab CE 11.10.8 to the latest (13.6.1).

Can i just run: apt install gitlab-ce ?

No, if you do that you will break it. This link should help:

Based on the path:

8.11.x -> 8.12.0 -> 8.17.7 -> 9.5.10 -> 10.8.7 -> 11.11.8 -> 12.0.12 -> 12.1.17 -> 12.10.14 -> 13.0.14 -> 13.1.11 - > 13.5.3

you are on 11.10.8, so I think best for you to upgrade to 11.11.8 first, and then follow all the paths after this for each and every version until you get to the latest.

Also, after each upgrade, make sure all background migrations have finished before attempting the next upgrade.

shows you the command to use to check this, if it’s “0” then you can do the next upgrade. If not, wait until it does report “0” before continuing. It can take a while.

1 Like

So I need to download the deb files of this versions and run the update one by one?

You can do it by supplying the version like this:

sudo apt-get install gitlab-ce=11.10.8-ce.0

I was able to update using the deb files…

Now I’m at version 13.5.3…

But if I run “apt list --upgradable” the gitlab 13.6.x not appear… why?

I solved the issue above about apt list …

But now after all this updates (without errors) but all my repositories are now showing this:

Looking at the file system I found this (in red my groups, but all empty):


I found this but without success…

Upgrade to 13.4 or higher versions will trigger a migration of all storage paths, due to a move to hashed storage (the @hashed name path visible in your screenshot) and the deprecation of legacy storage (group and project name paths):

Upon upgrading to 13.4, all projects still in legacy storage will be automatically migrated via a background migration.

Please check for ongoing background migration tasks that may be taking a while to complete due to the size and count of all stored entities across GitLab. Once they complete, your project repositories should be visible again:

sudo gitlab-rails runner -e production \
'puts Gitlab::BackgroundMigration.remaining'

The problem is that there is no background migrations running. I checked using:

sudo gitlab-rails runner -e production 'puts Gitlab::BackgroundMigration.remaining'

Each update i ran, I checked the migration work and waited for them.

Checking the Sidekiq I got a lot of CipherErrors:

At the red rectangle … after this I tired to rollback the hased respositories and migrate them again, then I start to get the “Projects::HashedStorage::RepositoryInUseError: Target repository ‘jjw/besser-core’ cannot be made read-only: Repository already read-only” in all projects…


Can be this the source of the problem Restored a backup without gitlab-secrets.json, how to solve? ?

I solved running

And then 8.11.x -> 8.12.0 -> 8.17.7 -> 9.5.10 -> 10.8.7 -> 11.11.8 -> 12.0.12 -> 12.1.17 -> 12.10.14 -> 13.0.14 -> 13.1.11 - > 13.5.3