Can not dismiss vulnerability

I recently incorporated a SAST scan (flawfinder) into our project. Things were “working” and I had vulnerabilities show up in the Vulnerability Report. I went through and dismissed a bunch, but i was left with one that i simply can not dismiss. I keep getting the following error when trying to update the status on the vulnerability report page:

“Failed updating vulnerabilities with the following IDs: 18175”.

If i open the vulnerability and update the status, it says it updated successfully, but then when i go back to the report page, it still shows as detected without a change in status.

Is this a bug? Is there any way i can reset the report and start fresh?