Cannot login into GitLab account


Yesterday I was able to login using the Google login and had the username abc (example). Today when I login by manually entering the email (same email used yesterday for the Google login) and password I have the username xyz.

My main problem is that I can’t see anymore the projects I had under the abc username.

Using the Google login leads to an error “Sign-in using google_oauth2 auth failed”.

More context
I do recognize the xyz username, I did indeed create this user some months ago, that I’ve forgotten about. I’m confused as to why yesterday when I logged in using the same email address, but using Google login, GitLab listed me as abc.

Yesterday when I made my first push I was asked for my credentials, but since I logged in using Google login I did not have a proper password to enter. So I accessed the GitLab settings and manually updated my password. I’ve had no problem pushing after that.

Fast forward to today when I see that I’ve been logged off of my abc account, so I try the Google login. This leads me to the error mentioned above. So I say to myself, ok this may be because I’ve manually changed my password.

I try manually entering the email I used yesterday for the Google login and the new password I generated. This logs me in into the xyz account, where I can’t see the project I’ve worked in yesterday.

What I’ve tried

  • Login with Google login -> “Sign-in using google_oauth2 auth failed”
  • Login manually -> logs into xyz
  • Login with abc username and password that worked fine yesterday -> “Invalid Login or password.”

Is there any way to login back intro the abc username?

Thank you so much to whoever takes the time to answer, any help is greatly appreciated! :smiley:

This is a GitLab forum. The title of your post is talking about GitHub not GitLab. Please change it if your issue is about GitLab.

Sorry, it was a typo, thank you!

About your issue, how many Google profiles do you have? Sometimes people have a different one at work and at home.

Are you sure that you are now using the same one, when using the Google login, as the one you used yesterday?

Yes, I’ve checked with my personal email too, sadly it only leads me to creating an entirely new account :frowning:

H @alina-gc,

this sounds like problem where our support engineers should have a look with you. Please go ahead and open a a new support ticket to recover your account.

Thanks for taking the time to investigate and describe your problem in detail. Please ensure to link this topic in your support ticket :slight_smile:


This was a big “I’m an idiot” moment.

So it turns out I was trying to login into, but the user I used yesterday was on (facepalm)

Thank you guys for all the help, I just hope I’m not the only clueless one and this thread will help someone else in the future as well :sweat_smile:

Sorry, have a good one!