Cannot reset password for root account

I have tried the root password reset options over a dozen times. They do not work. I installed the omnibus installation option a few hours ago. I have even restarted gitab multiple times. The authentication just does not work. Any ideas?

followed this link:
http://doc.gitlab.com/ce/security/reset_root_password.html

sudo gitlab-rails console production
user = User.where(id: 1).first
user.password = ‘secret_pass’
user.password_confirmation = ‘secret_pass’
user.save!
//replaced secret_pass with my new password

for restart:

gitlab-ctl restart (or sudo gitlab-ctl restart)
I even tried gitlab-ctl stop and gitlab-ctl start

This has now wasted a fair bit of my time and losing patience fast with gitlab.

thinking of avoiding gitlab altogether

1 Like

There is no need to reconfigure. I just tested this on a VM with Debian 8 following the instructions in the docs and it worked.

Are you following the steps to reset the password right after you install?

there was an issue with the DNS for the server which was causing the issue. The logon response was generic so that did not help in this case. Is there a specific log file anywhere (besides the nginx access/error logs) that would give more info on why the logon was not successful?
Thank you for looking into it.

You could use gitlab-ctl tail to see the logs of all services. You can also feed it particular ones like gitlab-ctl tail unicorn or gitlab-ctl tail gitlab-rails.

Hello! I have the same problem, but I’ve solve it!!! :partying_face:

I’ve solve this with changing root email to valid (e.g. root@mydomain.com)