Can't access project repository


I have problems accessing my project’s repository. When I try to view the repository via browser I get this error message:

The page you're looking for could not be found.
Make sure the address is correct and that the page hasn't moved.
Please contact your GitLab administrator if you think this is a mistake.

And when trying to clone the repository with Git Bash I get the following error message:

GitLab: You are not allowed to download code from this project.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

These both error messages seem to imply that I don’t have permissions to the project’s repository. However, I’m listed as a developer in the members list so I don’t see any reason why I wouldn’t be able to access it. I troubleshooted this with a project member who has master permissions, but we couldn’t find any solution to this. I also asked another member with developer permissions if he could access the repository, and he had no problems accessing it.

The UI also looks different than with my other project. I can’t see links to repository, pipelines, graphs, merge requests or snippets. Isn’t this how the UI looks with guest permissions?

1 Like

See here:

This problem should be fixed now, though you may need to delete the project and create a new one.

This issue doesn’t seem to be fixed with the current project (tried logging out and in), but I’ll let the project master know that we should recreate the project. Thanks for the help!

Will mark as solved later if recreating the project helps.