Can't add an application without specifying a scope


I’m running the latest GitLab Omnibus under CentOS 8.2. I had working GitLab with Mattermost and GitLab SSO stack. I’ve wanted to manually configure HTTPS for both GitLab and Mattermost services.

I’ve followed those documents:

It actually worked, but SSO broke, which is the expected behavior. Continuing to apply the official procedure, I’ve removed the Mattermost application from Admin Area > Settings > Applications. Next I’ve tried to reauthorize Mattermost. When I did, I got the following error message:

Sounds straightforward, but:

  1. The official documentation explicitly states that

    you do not need to select any options under Scopes .

  2. The pre-existing Mattermost authorization had an empty Scope section.

So, what should I understand or do from there in order to repair the SSO?

Best regards,

Exactly the same problem…

@ulysse68 Found out the documentation actually is wrong! According to some online source, the fact that default/auto-generated Applications doesn’t show any set scope is something inherited from older GitLab versions where scopes didn’t exist.
After running different tests, I ended up to the conclusion that I needed to select the “api” scope. “read_api” and “user_api” didn’t work for me, though it seems it did for others as I read on the Internet.

Now I have a last issue to fix where Mattermost refuses GitLab self-signed certificate. Didn’t find a working solution for CentOS 8. This is blocking me from going into production.

Right. I found a way of making it work, thanks! But as you said, the first time I configured the application, there was no need to specify a scope…
About your problem, I don’t experiment this – I use a Let’s Encrypt certificate.
Bon courage (j’imagine d’après ton pseudo qu’on aurait pu échanger en français?)!