Can't add Restricted domains for sign-ups

Can’t add additional domains to the “Restricted domains for sign-ups” in the Admin section. Tried as both Root user and myself, both set as Admins.

Don’t get an error or anything. Screen refreshes and shows the original domain that was entered.

I tried entering the additional domain on the second line (as instructed), and also entered on the same line after a comma (also, as the example shows). Both had the same effect, which was nothing.

From the log, it appears my change is being rejected and redirection is back to the same page:

Parameters: {"utf8"=>"✓", "authenticity_token"=>"[FILTERED]", "application_setting"=>{"default_branch_protection"=>"2", "default_project_visibility"=>"0", "default_snippet_visibility"=>"0", "import_sources"=>["github", "bitbucket", "gitlab", "gitorious", "google_code", "fogbugz", "git"], "version_check_enabled"=>"1", "admin_notification_email"=>"", "gravatar_enabled"=>"1", "twitter_sharing_enabled"=>"0", "default_projects_limit"=>"25", "max_attachment_size"=>"10", "session_expire_delay"=>"10080", "user_oauth_applications"=>"1", "signup_enabled"=>"1", "signin_enabled"=>"1", "restricted_signup_domains_raw"=>"", "home_page_url"=>"", "after_sign_out_path"=>"", "sign_in_text"=>"", "help_page_text"=>"", "shared_runners_enabled"=>"1", "max_artifacts_size"=>"100"}}
Redirected to