Can't connect to Remote Environment


hopefully this is the right forum. If not, please feel free to move.

I have just installed GitLab 16.2 and I am trying to connect it to a remote environment. I followed this tutorial: Tutorial: Connect a remote machine to the Web IDE | GitLab

But when I try to connect from the Web-IDE, I always get

An unexpected error occurred that requires a reload of this page.
The workbench failed to connect to the server (Error: Connection error: Unauthorized client refused: auth mismatch).

How can I debug this?


Still not able to connect.

I am wondering whether it could have to do with SSH keys? My Gitlab is a new instance and it tells me that I need to add an SSH key in order to be able to establish a secure connection between my computer and Gitlab. Might this also be required for Gitlab to contact the Remote Environment?

Hah, got it working.

I have an SSH connection to the Remote Environment host and get the token as described in the guide. On my Mac I copy it from the terminal window using the context menu (that opens up when you right click - or two finger click). Up to now, I kept pasting the token in the Gitlab browser window again using the context menu. Out of pure desperation, this time I pated it using + and this time it worked.

No idea why this made a difference, but apparently it did…