Can't fork Gitlab CE

I’m trying to fork the repository (https://gitlab.com/gitlab-org/gitlab-ce) but the application throws an error:

You tried to fork GitLab.org / GitLab Community Edition but it failed for the following reason:
– Name has already been taken

Please note that I don’t have any repositories in my Gitlab account. Before this error, it was waiting so long and throwing a generic error saying that the repository is not forked.

I had this issue as well.

There were two underlying issues:

  1. https://gitlab.com/gitlab-com/infrastructure/issues/2725 made the repository unclonable.
  2. When I finally could clone it, there were remnants that resulted directly in the error you’re describing.

My workaround was to create a new group and then clone the repository into the group’s namespace.

Thanks, I did it but now it throws 500 error. :confused:
I see the “Forking in progress.” message for 5 minutes but then it redirects me to 500 error page. It may be a timeout issue since the repository is big but I wonder how people are able fork the project. I tried forking it more than 10 times during the day but still no luck. :confused: