Changing email address for internal users

Hello,

I have a self hosted version of gitlab. I am trying to change the email address for the following 2 users, but the web admin is not letting me.

GitLab Support Bot (Internal)
GitLab Alert Bot (Internal)

The form contains the following errors:

  • Notification email can’t be blank
  • Notification email is invalid

There is no ‘notification email’ field on the edit form and the regular email address is correct. Can someone help me out please?

Thanks,
Boris

1 Like

Hi @tmmboris welcome to the gitlab community forum.

I suggest better to leave these accounts alone as they are internal accounts created by gitlab, and is most likely the reason why you cannot change them. I have also attempted actions with these accounts before myself and got the same errors. I decided just to leave them alone in case they actually break something.

Hello @iwalker,

I agree with leaving those 2 accounts alone for the most part. But if they send email, I need to be able to configure their email addresses. Otherwise it will cause havoc with my dkim/dmarc setup.

Regards,
Boris

True, I have dkim also. Not had them send any emails though so I don’t think its anything to worry about as such.

Should be editable though. I will see if there is a way to edit on my installation somehow by api perhaps and let you know.

Screen Shot 2020-10-20 errorr domain

User error entering the custom domain - during initial installation

In the admin area under. >> Preferences > Email
There are “Various email settings.” Including Custom hostname (for private commit emails)
gitlab.example.com
This setting will update the hostname that is used to generate private commit emails"

We have corrected the "Custom hostname " However both the support and alert users are going to the wrong domain. gitlab…example.com which of course is an invalid email.

Is there a quick and easy way to change these bot users to correct this ?

@tmmboris I checked my logs, haven’t seen an email during the last month from either of these accounts, so I expect they aren’t sending anything.

I didn’t try the above recommendation from the previous post but it could potentially solve the problem. I might try this in my lab environment first just to make sure that it doesn’t break anything. I do have a server for this, so will update in the next hour or two, maybe sooner.

Hmm, in my lab environment it’s a clean install of 13.3 or 13.4 (can’t remember now), and these logins don’t exist. Although I did set that custom field by setting it to users.noreply.domain.com instead of it having the users.noreply.hostname.domain.com. Everything seems to work, but then it’s a lab environment.

If you are not in too much of a hurry, and based on the info that these accounts don’t seem to send any email from what I’ve checked, I can get my production server backup and put it on a second server to check/test and let you know the outcome. I thought my lab install might have these users, but it seems they only show up on systems that have been upgraded from example, 12.x to 13.x or even earlier.

1 Like

Hello @iwalker,

I changed the ‘Custom hostname (for private commit emails)’ field to be mydomain.com. But that did not have any effect on the emails address for the 2 internal users. it i still @git.mydomain.com. My guess that is because gitlab is running on that domain. My gitlab version is 13.4.4 (e7d9e8b4224). Hopefully this issue will be resolved in one of the future upgrades. Thanks for all the help.

Thanks,
Boris

1 Like

I restored my production server to check/test this. I had the same as you it didn’t change. I’ve worked with the API, but cannot get it either. Same error as in web interface:

{"message":{"notification_email":["can't be blank","is invalid"]}}

so it seems we are restricted from being able to edit these users whatsoever. I did this using the root user as well.

Obviously we wouldn’t have this issue if we configured for example: mydomain.com

then all emails would be correct. The problem seems to occur, when we configure for example: gitlab.mydomain.com and then the system-generated users have the full hostname. And despite configuring the custom entry in the settings, it doesn’t help it.

I expect I could probably go into the postgres database and manually edit in here. But without not knowing the effects of this, I’ll not take the risk. I guess we’ll have to wait for now, maybe in the future it will be editable within the web interface or via API.

1 Like