CI/CD - production deployment error- dpl command not found

The pipeline .gitlab-ci.yml code successfully works till yesterday but today i got the error which says “dpl command not found”
the below is my .gitlab-ci.yml file

image: node:8.9.3

  - job1
  - test
  - production

  stage: job1
  script: "ls -l"

  stage: test
    - npm install

  type: deploy
  stage: production
  image: ruby:latest
    - apt-get update -qy
    - apt-get install -y ruby-dev
    - gem install dpl
    - dpl --provider=heroku --app=quailapp --api-key=$HEROKU_PRODUCTION_API_KEY
    - master

This is the log Generated,

Setting up rake (10.5.0-2) ...
Setting up libruby2.3:amd64 (2.3.3-1+deb9u2) ...
Setting up ruby2.3 (2.3.3-1+deb9u2) ...
Setting up ruby2.3-dev:amd64 (2.3.3-1+deb9u2) ...
Setting up ruby-dev:amd64 (1:2.3.3) ...
Setting up ruby (1:2.3.3) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
$ gem install dpl
Successfully installed dpl-1.9.6
1 gem installed
$ dpl --provider=heroku --app=quailapp --api-key=$HEROKU_PRODUCTION_API_KEY
/bin/bash: line 68: dpl: command not found
ERROR: Job failed: exit code 1

could you please tell me what is the solution this problem?

1 Like

yeah, i got the same error too.

I’m seeing it too. Just started yesterday.

It is working today. Looks to be related to the Ruby Docker image as mentioned in this Stack Overflow post.

its solved. guys !

See this thread -

this is the issue -

The Development team merged the code yesterday itself i think.

1 Like