CI Job failing without traces or logs

Hello folks,
First of all, sorry if the question has been already asked but i couldn’t find a similar issue anywhere.

I’m currently trying to setup a CI pipeline for an angular project which does the following:

  1. Clone the repo and install npm packages
  2. Builds the angular application
  3. Uploads the build output as artifacts
  4. Downloads the artifacts on another runner on another machine

During the process a weird issue is happening: when the runner tries to download the artifacts (or right before running the script) the job fails with no trace, log or output whatsoever.
The failing job is the “webadmin_deploy” job.

That’s the runner debug output: Screenshot by Lightshot
The two different traces shown in gitlab: Screenshot by Lightshot and Screenshot by Lightshot
My .gitlab-ci.yml configuration: stages: - init - clone - build - clean - deploy - -

Hoping to get any hint, thanks!

Hey @sickaesir ,

Do you already checked the “raw output” of your CI. There should be a button at the top of your job log view. This should show you the full output of your commands.


Hi @tonka3000,
Thank you for the reply, yes i’ve already checked them but didn’t include in the post for redundancy.
That’s the output of the two cases where the script fails:


I guess that you have a trouble bringing artifacts from one job to another.

I checked your pipeline and there are some things which are not optimal and I think you can reduce the count of jobs as well which would make it easier do maintain and maybe also get rid of the error as well.

I would suggest to reduce your jobs with following tips.

Use Custom build directories variable instead of the GIT_STRATEGY: none, which should you save a lot of boilerplate code, because you should now get the git clean for free.

I would join following jobs into a single one:

  • job_init
  • webadmin_cloning
  • webadmin_build
  • webadmin_clean

Use artifacts to transport your files to the next job and after_script: for clean.

The whole deploy jobs are interesting. So you use the artifacts from the buildserver-runner and deploy it to the webserver-runner as far as I understand it. So your webserver-runner is also your webservice. If you just have html, javascript and hmtl maybe also GitLab Pages could be a good option, but I see that you use cmd and powershell commands, so I would guess you deploy to a windows server. I also think your deploy job can be a single job.

With that you should have only two jobs and I would guess that you will also fix the error.


Thank you for your hints, i’ve managed to shorten my pipeline file consistently!
But sadly the problem still didn’t go away, here is my updated .gitlab-ci.yml config: stages: - build - deploy - clean variables: LC_ALL: " -

:thinking:. Try to use dependencies instead of needs, maybe this could help here.

Also paste the raw output of it is different then before.

Using dependencies i get the same raw output as needs: Screenshot by Lightshot

Do you have any proxy or something like that in your network?
Maybe the runner is misconfigured.

Has this runner ever worked?

Which version your runner have? Which version your gitlab instance have? Maybe an upgrade of the runner could fix that.

You can configure the runner to run in debug mode, maybe you will get more information.

Do you have any proxy or something like that in your network?

The GitLab installation itself is proxied behind nginx, further we’re using a js middleware for nginx to mask some GitLab resources behind our vpn or to be accessed by our internal server network only.
Got to say this is not the only pipeline we’ve got passing artifacts between jobs, yet it’s the only failing.

Has this runner ever worked?

Yes, there is even a similar pipeline to the one i’ve posted which does basically the same with laravel,
but that’s working.
Making my pipeline almost identical to the working one still doesn’t solve the issue.

Which version your runner have?

Currently i’m using gitlab-runner 13.4.1 on the build server and gitlab-runner 10.5.0 on the webserver

Which version your gitlab instance have?


You can configure the runner to run in debug mode, maybe you will get more information.

Already tried, you can check for the runner output on my first post.

I have read a post with similar problems some time ago but I could not find it anymore. The runner was also 13.4 and the solution was an upgrade to a newer version when I remember it correctly. Is the 10.5.0 a typo?

@sickaesir, could you please create a minimally-reproducible configuration?

I created a simple project that you can clone: thiagocsf-group / copy-artefacts · GitLab

It will run date in the build job, save the output in a file, collect the artifacts. Then, in the next job, it will download the artifact and dump its contents.

This should allow you to start narrowing-down the problem. I’m interested to know if this is an instance issue or just the particular project above.