CI_JOB_TOKEN sometime gives project not found

Hi, I have on-prem Gitlab 13.0.10 with gitlab-runner version 13.0.1 running docker on Centos7. with rather simple gitlab-ci.yml

before_script:
  - echo -e "machine gitlab.private\nlogin gitlab-ci-token\npassword ${CI_JOB_TOKEN}" > ~/.netrc
  - export GOPATH=/builds/go
  - export GOBIN=$GOPATH/bin

build:
  only:
    - master
    - release
    - stage
  stage: build
  image: gitlab.private/ma/golang112-builder
  script:
    - GO111MODULE=on go build -o bin/$APP_NAME

Sometime build fails with:

$ GO111MODULE=on go build -o bin/$APP_NAME
go: finding gitlab.private/ma/web v1.0.7-0.20200810084648-7376b04cf556
go: finding gitlab.private/ma/squirrel v0.0.0-20200806052249-456fb4275368
go: gitlab.private/ma/web@v1.0.7-0.20200810084648-7376b04cf556: git -c protocol.version=0 fetch --unshallow -f https://gitlab.private/ma/web.git refs/heads/*:refs/heads/* refs/tags/*:refs/tags/* in /builds/go/pkg/mod/cache/vcs/bd020e5d7a9c421b94eaea05b934ec35ba3e0f50b6950989e7fa7554d6ebb14f: exit status 128:
	fatal: repository 'https://gitlab.private/ma/web.git/' not found
go: gitlab.private/ma/squirrel@v0.0.0-20200806052249-456fb4275368: git fetch -f https://gitlab.private/ma/squirrel.git refs/heads/*:refs/heads/* refs/tags/*:refs/tags/* in /builds/go/pkg/mod/cache/vcs/121eabf05793a5f557e4a199fbe369ddd32ae6f93b43c41120d66ed0405c95f0: exit status 128:
	fatal: repository 'https://gitlab.private/ma/squirrel.git/' not found
go: error loading module requirements

Both dependencies are “Private”. Sometime build runs smoothly, sometimes not. Same problem existed on 12.10.9.

Please help me debug this issue.

Permission problems, please delete.