Commit & push doesn't fire push event

Hello,

I had a bitnami gitlab stack with gitlab 7.13.5. I wanted to upgrade, but bitnami made things lots harder, so I decided to install my own omnibus gitlab. I made a backup from the existing 7.13.5, installed the newest omnibus gitlab, and I couldn’t restore because of the huge version diff. So I’ve installed an omnibus gitlab 7.13.5. Made the restore, and upgraded to the latest version.

Now I have an omnibus gitlab 8.9.2, running on debian jessie, with 4gb ram. It works very well.

Except one thing. I had my old webhooks set up, when I clicked on test hook, it worked well (with jenkins CI), but when I pushing into my repo, it doesn’t trigger the webhook. Also there is one more thing, it doesn’t update the mentioned issue. E.g. if I write the issue number in the commit message it should appear in the issue, something like that: “mentioned in commit mygrp/myprjct@44484d23”. But it doesn’t appear.

Merge requests are working well, they are firing push events, and they update the issues as well.

Is there any suggestion about the mentioned problems?

Neither of them is a critical problem, but it’s annoying, I like to see how much work was in an issue, and it’s convenient if I don’t have to manually start my jenkins build.

Thanks,
Peter

Sorry guys, I solved it, after two weeks of googling… I found the gitlab trouble shooting guide.

The sudo gitlab-rake gitlab:check command found some issues, and made some suggestions to fix it, and the suggestions fixed my problems.

I had to run the create-hooks script, because I had a “migrate” when I restored my data.