Configuration Gitlab server

I am trying to use gitlab CE on my NAS.
On the machine 192.168.1.10 I have the PostgreSQL database and the redis server (use also by nextcloud).
In a lxc container 192.168.1.11 I have the gitlab.

In a first time I configured the gitlab with the distant database and it worked except that after two hours I got the message “502 Whoops, GitLab is taking too much time to respond.”
When I tried to restart gitlab I got time out for gitlab-exporter and puma
If I restarted the container it was working again.

I tried to improve my configuration. I removed the gitlab-exporter, I don’t know why it is not able to join the database, and I configured the redis server.
It was working for two hours and again the same problem. But now, even if I restart (gitlab or the container), I got the message “502 Whoops, GitLab is taking too much time to respond”.
I don’t know what to do, and I don’t understand the problem.

When I check /var/log/gitlab/gitlab-rails/application.log
I have this

 Cached record for ApplicationSetting couldn't be loaded, falling back to uncached record: could not connect to server: Connection timed out
        Is the server running on host "192.168.1.10" and accepting
        TCP/IP connections on port 5432?

The port is link with database, I didn’t change anything about it. When I check the error, it could be link with the redis server. But when I PING it I got a PONG. I am lost.