Creating wiki page results in 500 We're sorry, but something went wrong

I have tried to find information on the web on how to create a new page in the wiki, but does not find a good instruction.

This is what I did:

  1. Installed on a machine running Ubuntu 14.04.1 LTS 64 bit, server version.
  2. Registred a user via the web interface and succesfully confirmed the account.
  3. Created a private project via the web interface.
  4. In the web interface I opened the wiki.
  5. In the Content I entered a single line: [A page](dir/
  6. Pressed Create page and got “Wiki was successfully updated”.
  7. Clicked on the “A page” link on the home page, and got “Editing - dir/”
  8. Entered a single line “Some text.” in the Content.
  9. Clicked “Create page” and got:
    500 We're sorry, but something went wrong. Please contact your GitLab administrator if this problem persists.

After that, I upgraded GitLab to gitlab_7.8.0-omnibus-1_amd64.deb following Updating GitLab via omnibus-gitlab.
Tried again, but got the same error.

If I enter a link like [Another page](dir/another_page) in the home page content, the page is created without problems.

I think this is by design. Do not append .md to page names, just pick markdown in the dropdown Format menu, which btw is the default. You can use slugs with dashes (-), otherwise it gets escaped and produces an error.

However, I found a bug. If you do what you suggested:

go the pages tab and visit the newly created page you get a 404, because the url gets escaped and you see something like /wikis/dir%2Fanother_page. Replace %2F with a / and it should work.


I cloned the wiki and had a look:

root@localhost:/tmp/ ls -R
dir  home.markdown


So, it seems that GitLab have problems with dots in page slugs and also forces the extension .markdown. This fact I can not see in the documentation.

As you also can see, the was actually created as, but the page can not be viewed via the GitLab web interface.

I do not have the problem viewing the another_page that you have. Klicking on the link opens the URL http://localhost/janne/wiki-create-page-problem/wikis/dir/another_page and shows allright.

Bug reported here

And MR provided here