Deb packages for x86_64?

Hi,

Looking to move from source to Omnibus packages and struggled to understand why apt couldn’t find gitlab-ce when running Step 2. at https://about.gitlab.com/downloads/#ubuntu1404 . When I downloaded from https://packages.gitlab.com/gitlab/gitlab-ce?filter=debs and tried a dpkg install I then understood the issue - my Ubuntu wasn’t happy with AMD64 builds as it identifies as x86_64 / i386:

james@gitlabhq:~$ sudo dpkg -i gitlab-ce_8.0.1-ce.1_amd64.deb 
[sudo] password for james: 
dpkg: error processing archive gitlab-ce_8.0.1-ce.1_amd64.deb (--install):
package architecture (amd64) does not match system (i386)
Errors were encountered while processing:
gitlab-ce_8.0.1-ce.1_amd64.deb

Here’s how my system identifies.

james@gitlabhq:~$ uname -a
Linux gitlabhq 3.13.0-49-generic #83-Ubuntu SMP Fri Apr 10 20:11:33 UTC 2015 x8
6_64 x86_64 x86_64 GNU/Linux
james@gitlabhq:~$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS"

I think this is distinct from existing discussions around package issues and wondering if it’s a need to have additional builds available or a change in my setup - I deploy to (LXC) containers. I appreciate I may be missing something on the sysadmin side so also happy to hear “You should’ve done …”.

1 Like

apt install gitlab-ce=“version”-ce.0 worked for me to get the amd on my x86_64