Do GitLab have any compatibility matrix with GitLab API versions?

This is regarding GitLab APIs Version. I am creating a new IntelliJ IDEA plugin that connecting GitLab server by using gitlab4j APIs. I am getting unsupported error with the GitLab APIs version change. Is there any compatibility matrix among the GitLab API versions?