Docker build fails with cgroups mountpoint error

Problem to solve

Docker build fails on the first RUN step with:

cgroups: cgroup mountpoint does not exist: unknown

Other builds that run RUN steps from cache and all the other kind of steps (COPY, …) seems to work fine.

Steps to reproduce

Tried to re-run the build multiple times. Tried running past builds (that were working mostly from cached layers).

I’ve looked in the GitLab runner issues and haven’t seen anything like this.

Configuration

Add the CI/CD configuration from .gitlab-ci.yml and other configuration if relevant (e.g. docker-compose.yml). Alternatively, create a public GitLab.com example project that provides all necessary files to reproduce the question.

Versions

Please select whether options apply, and add the version information.

  • Self-managed
  • GitLab.com SaaS
  • Self-hosted Runners

Versions

  • GitLab runner: 16.11.0~pre.21.gaa21be2d

On a recent retry I’ve seen a new GitLab runner version 17.0.0~pre.88.g761ae5dd (761ae5dd) but that hit the same issue as well.

I have the same issue. Yesterday I had no problem with this using the gitlab-ci.yml I have used for multiple years. At about 4 PM CST, I received the same error and have not figured out a workaround.

It appears upgrading the docker image fixed my issue.

tags: [ saas-linux-medium-amd64 ]
image: docker:20.10.9
services:
- docker:20.10.9-dind

1 Like

Indeed, I’m using 19.03.12, that was set across our organisation but likely not correct. Did try with the latest 26.1.1 and that works too. This it’s does appear to be a need for a Docker image version bump.

Yes, Updating the docker image helped to resolve this issue

  image: docker:latest  # 26.1
  services:
    - docker:stable-dind  # 26.1

has the same error. Downgrade to docker:25 and 25-dind solved it.

1 Like

Thanks for all the feedback! I’ve tried a few versions, and just bumping from our original 19.x… made the build work.

However now I have no caching (everything seem to be rebuilt, while none of the caching settings have changed). I just wanted to check whether anyone else experiences that? If yes, I’ll break that out to another topic, if not, it might be something still with my setup.