Docker CI/CD stopped working

Hi, I have a CI/CD configuration that has worked well about one week ago, I deployed my latest code then. After 1 week, it suddenly stopped working, the job still run successfully, but I don’t see my latest code, or any new docker image or container created. Please help.

Here is my gitlab-ci.yml:

image: docker:19.03.12


  • docker:19.03.12-dind


  • deploy-staging

stage: deploy-staging

- echo “BE_BASE_URL=$BE_BASE_URL” >> “./.env”

- docker build -t atlas/frontend:stag .
- OldID=$(docker ps -f “expose=3000” -aq)
- ‘[[ ! -z $OldID ]] && docker stop $OldID’
- docker run -p 3000:3000 -d atlas/frontend:stag
- docker image prune -f
- staging

Here is my Docker file:

FROM node:12-alpine

Install node compile native

RUN apk add g++ make python

RUN mkdir -p /home/app

WORKDIR /home/app

COPY package*.json ./

COPY . .

RUN yarn

Install next-boost for deploy in production

RUN yarn add next-boost

RUN yarn build


CMD [ “npm”, “run”, “start:production” ]

I have run the job multiple times, they all succeeded. And I have tried to register a new runner on the same server, but no luck.

I’ve been having a similar issue since 3/17. Our CI pipeline built as expected for more than a year, and suddenly it stopped working. Or, more accurately, the pipeline succeeds but the files are not being deployed to the server. I haven’t found any errors so far. It appears that the entire process thinks it is working correctly, but clearly there is a disconnect somewhere.

I don’t know enough about our setup to give you much insight, unfortunately. But I’d be curious to hear if you find the cause, and if I come across any useful information I will share.