Docker image pulling issue

When the docker image is stored in public repository, we are able to pull the image from repo and use it in pipeline. But when docker image stored in private repository, we are not able to pull the image from repo.

Hi All ,

can you please help me for resolving the issue .

Please be patient when asking for assistance, waiting just one hour for someone to reply is unreasonable. You should at least give people a day or two to reply - you cannot expect immediate response. If you want immediate response, pay for support. This is a community forum where community members visit and help out. Assistance is not guaranteed, and should not be expected.

You need to authenticate with the docker registry to gain access if it is private. Assuming you mean using Gitlab Registry, then in pipeline:

echo "${TOKEN}" | docker login -u ${USERNAME} --password-stdin ${GITLAB_REGISTRY}

Thanks for replying. Currently i am using GitLab registry.
As you provide above command i tried but same error I getting.

pull access denied for

It depends where in the pipeline you want to use the image. If it is in the job definition:

my job with image from private registry:

follow this guide.

If you are trying to pull image as part of the script of job, follow this guide.