Docker login failed in CI job after Gitlab update from 13.3.1 to 13.6.2

i have private gitlab-ce instance on ubuntu 18.04
i am not able to upgrade gitlab-ce to latest version for one issue i am not able to solve:

when i run CI job, this line always fails

with this error message
Error response from daemon: Get denied: access forbidden

i am using 2FA for gitlab login
a also tried to manually create access token and use it
docker login -u me -p xxx
i have same response
Error response from daemon: Get denied: access forbidden

all worked on version 13.3.1
i tried to log in manually from 4 different servers but with same result

{“errors”:[{“code”:“UNAUTHORIZED”,“message”:“authentication required”,“detail”:null}]}

after reverting all changes with disk snapshot
C:\Users\Jakub>docker login -u me-p xxx
WARNING! Using --password via the CLI is insecure. Use --password-stdin.
Login Succeeded

my gitlab-runners are from deb package in shell mode

is here anyone with same issue i am facing right now?
please advice
thank you

more info to the subject
i tried to upgrade only to lastest patch - 13.3.9

i still have the same issue

i tried deploy token or even new personal access token
still the same problem

finally i find the solution
i hope it will help others

any installation will change /var/opt/gitlab/registry/config.yml


to http
just change back http to https and all is good

any other solution?