ED25519 SSH keys can connect git@gitlab.com but can't clone repo

Generated ED25519 SSH key as shown in this documentation in Windows and using gitlab.com

When I run

ssh -T git@gitlab.com

I get this message:

Welcome to GitLab @username

but when I try to clone my repo I get:

C:\project>git clone git@gitlab.com:ssmg/project.git
Cloning into ‘gameproject’…
Enter passphrase for key ‘/c/Users/abc/.ssh/id_ed25519’:
Enter passphrase for key ‘/c/Users/abc/.ssh/id_ed25519’:
Enter passphrase for key ‘/c/Users/abc/.ssh/id_ed25519’:
git@gitlab.com: Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

as you can see I enter the passphrase 3 times then it failed.

I tried removing and creating SSH key 3 more times to be sure I miss a step but didn’t. And scrape all info I could find about this problem but couldnt solve…

“Any” help appreciated :slight_smile:

Anyone who faced with this issue do not copy paste passphrase!

1 Like