Email - No confirmation email received

One of our Team member unable to get an email for a merge and commit request as he has not received an email account confirmation email.

1 Like

Hey @Kavit.patel, welcome to the GitLab Community Forum! :tada:

Are you on GitLab.com? If so, please submit a support ticket for this.

I’m having the same issue. I’ve tried so, so many fixes in vain. Running Windows 10 atm.

1.) I was able to sign in to my GitHub account on Github.com, but for some reason I get an “email not verified” error when I try to use my Github to sign into Gitlab.com. I was somehow able to create an account on the forums with the same configuration. I just used my Github account.

2.) I tried the same steps above but without script or ad blockers, and in a different browser… no dice.

3.) I tried to resend the confirmation email to my Github account, and I get this error: Csrf detected . I don’t believe I am a victim of cross site request forgery, and even if I was, when attempting this on both a Linux and an Android device, no dice, same error.

4.) I say “forget this” and I make a new account, which works. I go to the email page, and it says that my email is verified. Good! But then, after using git --config global and verifying that the email and credentials match the newly created account, I still get an email not verified error… even though it’s already verified on Gitlab (or at least, it says that).

5.) I check the config for my ssh and it does point to the proper directory and file - .ssh/config . There should not be an issue there.

I am at my wits end. I should say that my account is managed by my university, but I created an account like this before without issue. It is only an issue now, within the past two weeks or so.

Thanks for your time. Have a good day.

@en-eight As with the other user, please submit a support ticket. We cannot assist with account access issues like this via the public community forum.

I submitted a ticket and I was told that
“Please note, you have opened this ticket through our paid support channel and we were unable to automatically determine whether you have a license to a self-managed GitLab installation or a subscription to GitLab.com. If you do not have a GitLab.com subscription, a self-managed license, or are on a trial, be aware that only community support is included; consider searching for and posting your question in our community forum.”

Is there another support channel I can use?

Fixed, see below

Hello, I found a fix that worked for me. The credentials weren’t cached properly- try giving this a shot. https://stackoverflow.com/questions/15381198/remove-credentials-from-git