Error 500 when creating or editing wiki pages

Hi there,

i have a local gitlab installation running on Debian (installed via debian package).

Everything is working fine, but todayi started using the wiki-feature (on a non-empty repository).

I could create 2 pages fine, but after that, every time i try to add a new page the moment i am adding content and press ‘save’ i get a 500 error. Editing or trying to delete existing pages results in the same error.

I ran “gitlab-rake gitlab:check RAILS_ENV=production” but no errors were reported.

I would appreciate any hint wehre i could check for the error or a hint on how to fix this - even reseeting the wiki-content (there is not much yet) would be a possible solution.

In another Project i can create, delete and update pages quite fine. I only see 2 pages in the broken Project without any special characters, but it might be a problem that i created a page containing an ‘ü’ in the title (and this is not able to show up and causing this problems?) - so maybe a manual reset to the wiki (if posssible) would fix this behaviour.

Thanks in advance!

1 Like

I have the same problem here!

SO: Ubuntu 14.04
GitLab Community Edition 8.4.4 9c31cc6

Still only applying to one Project - Production.log contains:

Encoding::CompatibilityError (incompatible character encodings: UTF-8 and ASCII-8BIT):
app/models/project_wiki.rb:110:in delete_page' app/models/wiki_page.rb:162:in delete’
app/controllers/projects/wikis_controller.rb:83:in `destroy’

so it looks like there is an encoding error.