Error 500 when saving settings as admin

Hi,

when I’m trying to save settings as admin I get an error 500:

==> /var/log/gitlab/gitlab-rails/production_json.log <==
{
“method”:“PATCH”,
“path”:"/admin/application_settings/general",
“format”:“html”,
“controller”:“Admin::ApplicationSettingsController”,
“action”:“general”,
“status”:500,
“error”:“OpenSSL::Cipher::CipherError: “,
“duration”:85.94,
“view”:0.0,
“db”:45.97,
“time”:“2019-09-24T11:24:02.339Z”,
“params”:[
{“key”:“utf8”,“value”:“✓”},
{“key”:”_method”,“value”:“patch”},
{“key”:“authenticity_token”,“value”:"[FILTERED]"},
{“key”:“application_setting”,“value”:
{
“signup_enabled”:“0”,
“send_user_confirmation_email”:“0”,
“domain_whitelist_raw”:"",
“domain_blacklist_enabled”:“0”,
“domain_blacklist_raw”:"",
“after_sign_up_text”:""
}
},
{“key”:“blacklist_type”,“value”:“raw”}
],
“remote_ip”:“MY_IPV6_ADDRESS”,
“user_id”:1,
“username”:“root”,
“ua”:“MY_BROWSERS_UA_STRING”,
“queue_duration”:null,
“correlation_id”:“1fb83334-19b3-446f-a7e8-200b9a63611c”
}

What surprises me is the line “error”:"OpenSSL::Cipher::CipherError: ". Isn’t there something missing? When I see related posts of other people, the description of the openssl error is more detailed.

Information that might be vital:

  • nginx is disabled.
  • GitLab is running with apache2 wich is running in a chroot environment.
  • openssl command is running well in chroot environment.
  • GitLab is (sadly) not running chrooted right now and is accessed through proxy
  • directories
    /opt/gitlab/embedded/service/gitlab-rails/public
    /var/opt/gitlab/gitlab-rails
    are bind-mounted into chroot environment and accessable by apache2
  • ssl is setup in apache2 vhost-config but it doesn’t work either with ssl on or off

Disabling public signup is most important right now. It would be a help already if anybody knew away around it. Like editing the settings without the web frontend in the config files maybe.

Kind regards

This might be important:

locate .secret

Does not return a result. There is no file with that name on my system.

Lots of search results suggest that there must be a .secret file. However they also state that it’s created automatically on installation. I ran dpkg-reconfigure but that didn’t generate a file of that name either.

It would be easier to help if it was easier to understand what you’re doing.

But I’m guessing and my main question is: why are you not using the Application settings API?

Thanks for the repy grove. Sorry, I’m new to this software.

What I was doing is, that I wanted to disable sign_ups on the welcome page. To do so, I logged in as root went to the admin settings, selected the category signup and then removed the checker from the enable signup option. When hitting the save settings button after that I get to an error 500 page. I then used “gitlab-ctl trace” to get the error message I put in the first post.

I hope that clarifies it. Feel free to aks more questions.

OK, I’ve already suspected that something went wrong during my installation. I’ve accidentally installed gitlab-cc first. Then I’ve deinstalled it and installed gitlab-ce. That might have caused the trouble.

I’ve uninstalled gitlab with “gitlab-ctl uninstall”. Then I ran “dpkg purge gitlab-ce” which returned lots of errors. I then manually deleted the countles files, that were still left on my system, just keeping a backup of gitlab.rb. I’ve installed gitlab-ce again, restored my configuration file and ran “gitlab-ctl reconfigure”. After that I was finally able to store my settings (the way I’ve described before).