Error Gitlab Runner in Windows 2008 R2

Hello,

I’m having this error and I can not solve it, I already searched for something on the net and I still did not succeed. I am using the local Runner on a windows 2008 machine that uses proxy to authenticate the internet, however the authentication is ok and working. I can clone the repository of the windows machine by calling gitlab, but when I use the automated build process calling the local machine runner it gives the following error.

Running with gitlab-runner 11.1.0 (081978aa)
on adm-dev-01 d4dce99c
Using Shell executor…
Running on HOWDECM001FST…
Cloning repository…
Cloning into ‘C:/gitlab/builds/d4dce99c/0/grupo/subgrupo/projeto’…
fatal: unable to access ‘https://gitlab-ci-token:xxxxxxxxxxxxxxxxxxxx@gitlab.com/grupo/subgrupo/projeto.git/’: error setting certificate verify locations:
CAfile: C:/Program Files/Git/mingw64/libexec/ssl/certs/ca-bundle.crt
CApath: none
The system cannot find the path specified.
Checking out b5d12d3f as build_teste…
fatal: not a git repository (or any of the parent directories): .git
ERROR: Job failed: exit status 128

I tried to make some solutions using the ideas from the links below:

Thanks,

Fabio Santos

Hi, I’ve faced the same issue. Something is broken in “cmd” shell executor.
I’ve solved the issue by using “powershell” executor.

1 Like