Error trying to access CI/CD project from another project within the same group

I am trying to run a CI/CD within a group that points to a ci-templates project. However when I run it through the CI Lint, I get this error: Status: syntax is incorrect

Error: Project testProject/ci-templates not found or access denied!

How do I run CI/CD scripts in a different project? Do I need to use Deploy Keys or have certain SSH keys setup? I have multiple projects, so that’s why I want all the CI/CD scripts in a separate project so that all the other projects can utilize the CI/CD scripts. Another team has this setup, and it working, but I can’t find any setup differences.

This is the contents of my .gitlab-ci.yml file:
stages:
- build
- test

include:
  - project: 'testProject/ci-templates'
  - ref: develop
  - file: /yamls/compile.yaml

Here’s the compile.yaml:
maven_build:
stage: build
image: maven:3-jdk-8
script:
- . /scripts/mvn_compile.sh

I am running on self-managed GitLab instance, version 11.11. We stood up our own GitLab runner and that is version 13.2.0. Both projects are within the same group and the visibility is set to ‘internal’. I would expect that my testProject should be able to access the ci-templates project and run the appropriate script. Any help would be appreciated.