Error trying to register gitlab-runner

Hello, i am having trouble registering the gitlab runner on our server to point to our coordinator btw the gitlab server is running inside docker container in a centos 7 server.
The git lab coordinator is accessible so it doesn’t have any connectivity issues, so far i’ve tried using version tag 1.11.1 of gitlab runner docker container as other suggested but the problem is still ERROR: Registering runner… failed runner=censored status=401 Unauthorized PANIC: Failed to register this runner. Perhaps you are having network problems.What could be problem

btw my gitlab-ce version is 12.2.4

I sometimes need to “reset the runners registration token” on the admin/runners page, and then make sure I use the new registration token. What is the exact command you’re using?

i tried resetting the token but still the same error: 401. I am using gitlab-runner registry command.

Now i am able to register the runner using the IP not the domain name.Consider my problem as fixed.