Error upgrade to: 16.0.1

升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 0 B/1,420 MB 的归档。
解压缩后将会空出 248 MB 的空间。
读取变更记录(changelogs)… 完成
(正在读取数据库 … 系统当前共安装有 134582 个文件和目录。)
准备解压 …/gitlab-ee_16.0.1-ee.0_amd64.deb …

  • gitlab_rails[‘gitlab_default_can_create_group’] has been deprecated since 15.5 and was removed in 16.0. Starting with GitLab 15.5, this setting cannot be controlled via the configuration file anymore. Follow the steps at Account and limit settings | GitLab, to configure this setting via the Admin UI or the API
    Deprecations found. Please correct them and try again.
    dpkg: 处理归档 /var/cache/apt/archives/gitlab-ee_16.0.1-ee.0_amd64.deb (–unpack)时出错:
    新的 gitlab-ee 软件包 pre-installation 脚本 子进程返回错误状态 1
    E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi, please translate the question into English so that everyone can help.

Looking at the error message, I’d guess that gitlab_rails[‘gitlab_default_can_create_group’] needs to be removed because it was deprecated and now removed. After removing it, run the upgrade again, and follow the UI settings instructions to apply the new behaviour.

1 Like

Thanks for your answer, I’ve tried removing gitlab_rails[‘gitlab_default_can_create_group’] from the configuration file gitlab.rb, but it doesn’t work and I still get the same error when I re-upgrade gitlab

Sorry, it was my mistake, I forgot to run the gitlab-ctl reconfigure command

1 Like

No worries, glad you were able to fix the problem :slight_smile: