ERROR: You are not allowed to access projects in this namespace

,

Starting sometime between last night and today morning (APAC / GMT+8), we are unable to access any of our existing repos on the command line, via both SSH / HTTPS.

$ git clone git@gitlab.com:finverse/test-project.git
Cloning into 'test-project'...
remote:
remote: ========================================================================
remote:
remote: ERROR: You are not allowed to access projects in this namespace.

remote:
remote: ========================================================================
remote:
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

We have not changed any namespace / group / permissions in this time, and everything worked fine yesterday.

Anyone else affected by this? I am guessing maybe gitlab.com deployed some change which broke permission evaluations or similar.

I also made an issue in gitlab: Unable to access projects in namespace (GitLab Enterprise Edition 16.9.0-pre 990edf60f88) (#17497) · Issues · GitLab.com / GitLab Infrastructure Team / production · GitLab

We’ve identified the issue, seems it was related to this feature flag being rolled out 13 hours ago: [Feature flag] Rollout of `enforce_ssh_certificates` (#426235) · Issues · GitLab.org / GitLab · GitLab .

Disabling the “Enforce SSH Certificates” option has fixed it for us.