Errors after upgrading to 9.0

Users are getting errors after upgrading to v9.0:

Pull:
Error encountered while fetching: early EOF

Push:
fatal: git-http-push failed
error: failed to push some regs to 'https://… https://...

Any help would be appreciated.

I’ve tried running gitlab-ctl reconfigure. But that didn’t help.

Thanks,
Craig

Hi!

Have you tried to reboot server after upgrading? I’ve got the same problem and it was fixed after reboot (and maybe some regular OS updates).

Doh! That fixed it… Thank you very much!

I can’t tell you how many times I’ve told someone else to try that… I guess I need to heed my own advice!

Reboot fixed this for me as well. I was getting the same error after the upgrade to 9.0.0 ( ran yum update on CentOS server and did not reboot the server).

When trying to push to any branch after upgrading I got the error:

error: failed to push some refs to https://mygitlabserver/repo.git

Also when I tried to pull a branch I got an “Unexpected merge result” error, or something to that effect.

Rebooting the GitLab server fixed the problem. Now running GitLab CE 9.0.0 with no issues so far.

Thanks all!