External URL wilth alternate port number not working anymore after update to 8.10.0

Hi,

I’ve just updated to 8.10.0 from 8.08.

In /etc/gitlab/gitlab.rb I’ve set the “external_url” to https://git.example.com:3000. This has always worked for us.

However, after the update to 8.10 GitLab redirects to “https://git.example.com/user/login” without the desired port number. Does anyone know how to fix this?

Are you using GitLab behind a reverse proxy?

Which web server are you using? If nginx try adding the following and reconfigure

nginx['listen_port'] = 3000

No I’m not using a reverse proxy.

I’ve tried setting nginx[‘listen_port’] and nginx[‘listen_port_https’], but it doesn’t fix the issue.

This looks to have been introduced in 8.10.0 but has been fixed by the latest 8.10.1 release.

See, https://about.gitlab.com/2016/07/25/gitlab-8-dot-10-dot-1-released/ and the related MR; https://gitlab.com/gitlab-org/omnibus-gitlab/merge_requests/887

Please upgrade to fix the issue

Thank you! The update solved my problem.

1 Like