Fatal: reference is not a tree

Hi Team,

We are on GitLab 6.2.1-0 / Git 1.8.3
I was trying to accept the merge request over from develop branch to prod branch, and GitLab UI did not allow to accept the merge request
It was working up until we did a recent reboot of the GitLab server and all of a sudden one of the project started to show up “fatal: reference is not a tree:” errors in host.log

indent preformatted text by 4 spaces

February 16, 2016 10:29 -> ERROR -> Command failed [128]: /opt/gitlab-6.2.1-0/git/bin/git --git-dir=/opt/gitlab-6.2.1-0/apps/gitlab/gitlab-satellites/projectname/.git checkout develop

fatal: reference is not a tree: develop

February 16, 2016 10:29 -> ERROR -> Command failed [1]: /opt/gitlab-6.2.1-0/git/bin/git --git-dir=/opt/gitlab-6.2.1-0/apps/gitlab/gitlab-satellites/projectname/.git push origin prod

error: src refspec prod does not match any.
error: failed to push some refs to ‘/opt/gitlab-6.2.1-0/apps/gitlab/repositories/projectname.git’`

Navigating to the git project directory, shows it is currently on __parking_branch, wherein all other projects show the develop branch

cd /opt/gitlab-6.2.1-0/apps/gitlab/gitlab-satellites/projectname git status On branch __parking_branch nothing to commit, working directory clean

I deleted and recreated the problematic satellite directory by running below command. However, the merge request doesn’t work and noticed git status still shows __parking_branch.

bundle exec /opt/gitlab-6.2.1-0/apps/gitlab/htdocs/bin/rake gitlab:satellites:create RAILS_ENV=production

Any pointers highly appreciated.

Any pointers please?

Any clues on why this is happening? I am kind of lost, have tried recreating the satellites directory many number of times, but no help. Dont see any issues with pushing / pull to the develop branch, Its all that GitLab Merge requests is failing. I tried creating the branch itself as a new develop branch, however that doesnt help either. Somewhere in the DB, I assume GitLab may have marked develop branch of the project as corrupted, so it won’t proceed further beyong the __parking_branch