Fetch is failing on gitlab.com

Hey guys, git pull & git fetch are failing tonight on one of my private repos with the following error:

error: unpack-objects died of signal 9
fatal: unpack-objects failed

I uploaded a maxmind database we pay for to the repo and it looks like I can’t pull anything on the server. After some googling, I discovered that it seems to be a process issue on gitlabs side? How do you even report this?

Thank you

Signal 9 means that it got killed. I found an issue similar to yours which explains that it could be failing due to not enough memory. Have you tried running the git repack and see if that fixes the error for you?

I just did, it’s still failing. It sounds like Gitlab is having an issue allowing the pull of this and it’s literally not updating. I can’t wait much longer, I’ll have to move our repos if we can’t get attention on this.

edit: I tried submitting a ticket and because we don’t pay, it was instantly closed. I’m not sure how else we would get support for this issue. If anyone has any other ideas, I would appreciate it. In the mean time, I think we’re going to have to push to github.com and possibly move.