Getting 403 error message when cloning via a gitlab-runner running through Openshift operator


I’m struggling to get a CI/CD pipeline running with the Gitlab operator installed on OCP. SInce a few weeks I get a message

fatal: unable to access ‘https://xxxxxxxxxxxxxxxxxxxxxxxxxxx.git/’: The requested URL returned error: 403

It worked before but now I can’t get it working anymore

These are the involved components and there version

Gitlab : 14.3.1-ee
Gitlab OS : RHEL 8.4 (firewalld off, selinux ; permissive)
Openshift : 4.7.30
Gitlab operator: 1.3.0

I configured both a group runner and a shared runner both give the same result when running the pipeline.

Does anybody have an idea what is causing this or what is missing in the config to get the repo cloned?

If more info is needed please let me know.

Thank you already for any feedback


I installed now a shell gitlab runner on the same server as the gitlab instance and I get the same so it seems the issue is not related to the operator in Openshift but that any gitlab-runner (OCP or non-ocp) can’t clone repo’s anymore.

Still wondering why this suddenly started to happen…

Will investigate further but would be great to get some more input/feedback if you have.

Thank you


Ok, excluding things one by one, I excluded now the runner as well and I got the same message just when issueing a git clone command.

So I started to play around with DNS settings and after informing myself to our system administrators it seems that cloudflare is involved in the set up resulting in different IP addresses.

So it seems to be a DNS/Cloudflare thing that will need to be sorted out.