a few months ago I installed gitlab-ce on my Ubuntu server her locally. I am accessing gitlab through apache2 as proxy and everything is running fine. I can use the web frontend as well as accessing the repository out of Visual Studio 2019. Great.

But since a few days I am getting problems. Repository access through Visual Studio is still fine. But if I try to look in any file on the web frontend (Repository/Files) I am getting an empty page. Chrome shows ERR_CONNECTION_CLOSED as error and Firefox PR_END_OF_FILE_ERROR. The file listing itself is shown corretly.

I tried to dig down in the logs but I only find in nginx/gitlab.access.log the following entries a few time. - - [07/Mar/2020:09:52:50 +0100] “- -” 400 150 “” “-”

Accessing with my iPad works fine…

Same behavior by adding a new issue: clicking in the top bar on issues, selecting the project to add issue to and then click on "New issue in " and bang… Also in the log the same entry. But I can add an issue under my project / issues / list “new issue” without any problems.

It looks like that only a few parts in the framework are affected, but most of the site is working fine. So I guess it cannot be a problem with the apache proxying. To verify I logged in directly on the nginx port and not using the proxy, the problems remaining.

I switched the loglevel to debug and tried to grep through the logs to find any entry according selected file, but I found only 200er entries and nothing special…

Any ideas where to dig deeper in the logs or how to solve these issues?

BR Henning

1 Like