Git clone on bundle file from gitlab backups

I had a corrupt repo, I resolved it by removing this repo.

I’ve working version of this repo in backups. Inside backups I found .bundle file of the repo.

Now the trouble. I cannot do anything with this bundle, gitlab doesn’t allow restoring from .bundle file.

if I run git clone on it, it errors out: “does not look like a v2 bundle file”

I’m out of options… what do you suggest?

bundle is a Git internal command. Follow the documentation

I was under same impression, but none of these commands work on .bundle in gitlab backup tar.

They give the error I described in the question.

@sandrodz: I’m having a similar problem, have you already been able to solve yours?

Here goes my description:

System Information

  • running GitLab CE on an Ubuntu 14.10, details see below
  • Installed GitLab CE from Omnibus Package.

Problem Description:

  • used backup-instructions from GitLab Documentation to create a cron-based backup.
  • extracted .bundle-file of a backup. Trying to unbundle on a Win7 machine: Here, git version prints “git version” (I also tried git version 1.8.1)
  • referred to Git Documentation, and tried “git bundle unbundle”, this yields the same msg as "git bundle verify ": error: ‘origin/repo.bundle’ does not look like a v2 bundle file

I would be so glad if someone could offer advice on how to work around this “v2”-issue.

Thanks a lot in advance!

Gitlab Overview in the admin area says:
GitLab 7.13.2, GitLab Shell 2.6.3, GitLab API v3, Ruby 2.1.6p336, Rails 4.1.11

@phil no luck unfortunately.

Thanks, @sandrodz for your quick reply!

This issue seems to be relevant to a lot of other people, which are trying to restore backups. For example, see here: GitLab CE Issue

It would be so great if someone (maybe even the GitLab team!) could provide a solution or guideline on how to solve this. This issue is actually preventing my company from moving to GitLab-based repositories.

According to the backup script of repositories, a [project_name].bundle file is a tar file. So I tried extracting files from .bundle file with tar command and successfully got a bare repository.

I don’t know the reason why the repo backup file is a tar archive and the file has .bundle extension. The wiki backup file is truly a bundle file.

Thank you so much @takuyais, you seriously ended a tedious and so far unsuccessfull search of mine! It is indeed possible to just untar a .bundle-file with the archiver of your choice.

@sandrodz this should help you, too!

Kind Regards,